[PATCH 1/5] ptrace: add PTRACE_SYSCALL_INFO_SECCOMP_SKIP

Oleg Nesterov oleg at redhat.com
Fri Jul 3 09:58:11 UTC 2026


On 07/02, Renzo Davoli wrote:
>
> On Thu, Jul 02, 2026 at 04:47:08PM +0200, Oleg Nesterov wrote:
> > On 07/02, Oleg Nesterov wrote:
> > Wdyt about something like below?
>
> I like it.

Good,

> I have one comment:
> > +	if (ptrace_get_syscall_info_op(child) != info.op) {
> > +		if (info.op != PTRACE_SYSCALL_INFO_EXIT)
> > +			return -EINVAL;
> > +		force = true;
> > +	}
>
> I have found the behavior "negative syscall number => skip syscall" defined
> only for PTRACE_EVENT_SECCOMP in the manual. I'd restrict the option to this
> case, for safety.

Well, this simply means that the manual is incomplete. And whatever we do, we
will need to update it anyway when/if we add the new behaviour.

I don't think it makes any sense to restrict the new feature to _SECCOMP...

> A minimal detail: I'd also rename "force" into "skip" or "skip_syscall", just
> for the sake of readability.

Ok, I agree with any naming.

> Dmitry: does this proposal have counter effects for strace?

Oleg.



More information about the Strace-devel mailing list