[PATCH v8] tests/fcntl.c: add test for print_f_owner_ex

Dmitry V. Levin ldv at altlinux.org
Wed May 2 00:30:48 UTC 2018


On Mon, Apr 30, 2018 at 05:54:54PM +0800, Zhibin Li wrote:
> *tests/fcntl.c include <stdarg.h>

I don't see any include <stdarg.h> anymore. :)

> (test_f_owner_ex_type_pid, test_f_owner_ex_umove,

Looks like test_f_owner_ex_umove has been renamed.

> test_f_owner_ex): New functions.
> (main): Use test_f_owner_ex.
> ---
>  tests/fcntl.c | 53 +++++++++++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 53 insertions(+)
> 
> diff --git a/tests/fcntl.c b/tests/fcntl.c
> index 4f62ca2a..c05d00a1 100644
> --- a/tests/fcntl.c
> +++ b/tests/fcntl.c
> @@ -69,12 +69,65 @@ test_flock64(void)
>  #endif
>  }
>  
> +static long
> +test_f_owner_ex_type_pid(const int cmd, const char *const cmd_name,
> +			 const int type, const char *const type_name,
> +			 pid_t pid)
> +{
> +	TAIL_ALLOC_OBJECT_CONST_PTR(struct f_owner_ex, fo);
> +
> +	fo->type = type;
> +	fo->pid = pid;
> +	long rc = invoke_test_syscall(cmd, fo);
> +	printf("%s(0, %s, {type=%s, pid=%d}) = %s\n",
> +	       TEST_SYSCALL_STR, cmd_name, type_name, fo->pid, sprintrc(rc));
> +
> +	long rc_efault = invoke_test_syscall(cmd, (void *) (uintptr_t) fo + 1);
> +	printf("%s(0, %s, %p) = %s\n",
> +	       TEST_SYSCALL_STR, cmd_name, (void *) (uintptr_t) fo + 1, sprintrc(rc_efault));

The code would be more readable if you assigned the address
	(void *) (uintptr_t) fo + 1
to a variable.

> +
> +	return rc;
> +}
> +
> +static void
> +test_f_owner_ex_umove_or_printaddr(const int type, const char *const type_name, pid_t pid)
> +{
> +	long rc = test_f_owner_ex_type_pid(ARG_STR(F_SETOWN_EX),
> +					   type, type_name, pid);
> +	if (!rc)
> +		test_f_owner_ex_type_pid(ARG_STR(F_GETOWN_EX),
> +					 type, type_name, pid);
> +}
> +
> +static void
> +test_f_owner_ex(void)
> +{
> +	unsigned int i;
> +	unsigned int j;
> +	static const struct {
> +		int type;
> +		const char *type_name;
> +		pid_t pid[2];
> +	} a[] = {
> +		{ ARG_STR(F_OWNER_TID), { 1234567890, 20 } },
> +		{ ARG_STR(F_OWNER_PID), { 1298126790, 30 } },
> +		{ ARG_STR(F_OWNER_PGRP), { 1294567890, 40 } }
> +	};
> +
> +	for (i = 0; i < ARRAY_SIZE(a); i++) {
> +		for (j = 0; j < ARRAY_SIZE(a[0].pid); j++) {
> +			test_f_owner_ex_umove_or_printaddr(a[i].type, a[i].type_name, a[i].pid[j]);
> +		}
> +	}

We use loop initial declarations in new code, e.g.

	for (unsigned int i = 0; i < ARRAY_SIZE(a); i++)
		for (unsigned int j = 0; j < ARRAY_SIZE(a[0].pid); j++)
			...

> +}
> +
>  int
>  main(void)
>  {
>  	create_sample();
>  	test_flock();
>  	test_flock64();
> +	test_f_owner_ex();
>  
>  	puts("+++ exited with 0 +++");
>  	return 0;

Besides that, the test looks OK.


-- 
ldv
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
URL: <http://lists.strace.io/pipermail/strace-devel/attachments/20180502/aa555e2f/attachment.bin>


More information about the Strace-devel mailing list