Problems Using strace with Ubuntu 11.04

Steve Bennett steveb at
Fri Sep 2 01:31:52 UTC 2011

On 01/09/2011, at 2:41 AM, William R Agosto Padilla wrote:

> Dear Linux Experts,
> I have installed Ubuntu 11.04 recently. When I tried using strace, I got an error message that the modules couldn't be found. A sure sign that strace was not included in the distribution that I got. I installed strace  strace_4.5.20-2.3ubuntu1_i386. However after a restart, I am not able to get strace to work. When I run the command:
> "strace -e trace=network -o ~rkarne/Documents/strace_out.txt" 
> I get a man page explaining the strace and command options, but it does no run the command itself. Are you aware of any problems with strace with Ubuntu 11.04? Also, is "dtrace" the same thing as "strace"? What else do you recommend I do to be able to trace various processes?
> Very Respectfully,
> William

Check the man page.
Where is the name of the program you are tracing?

Start simple.

$ strace /bin/ls


µWeb: Embedded Web Framework -
WorkWare Systems Pty Ltd
W:      P: +61 434 921 300
E: steveb at   F: +61 7 3391 6002

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Strace-devel mailing list