[PATCH] remove dead "ifndef CLONE_PTRACE" branch, make setbpt easier to read

Denys Vlasenko dvlasenk at redhat.com
Thu Jun 23 14:07:17 UTC 2011


On Thu, 2011-06-23 at 17:26 +0400, Dmitry V. Levin wrote:
> On Wed, Jun 22, 2011 at 01:48:19PM +0200, Denys Vlasenko wrote:
> [...]
> > --- strace.6/util.c	2011-06-22 00:19:30.268714125 +0200
> > +++ strace.7/util.c	2011-06-22 13:32:30.653923439 +0200
> > @@ -1494,9 +1494,9 @@ setbpt(struct tcb *tcp)
> >  		return 0;
> >  #  endif
> >  
> > -	case SYS_clone:
> > +	case SYS_clone: ;
> >  #  ifdef SYS_clone2
> > -	case SYS_clone2:
> > +	case SYS_clone2: ;
> >  #  endif
> >  		/* ia64 calls directly `clone (CLONE_VFORK | CLONE_VM)'
> >  		   contrary to x86 SYS_vfork above.  Even on x86 we turn the
> 
> I wonder what this change was made for?

Labels cannot be used on declarations. Looks down:
the next statement is a declaration.

-- 
vda







More information about the Strace-devel mailing list