Problems Using strace with Ubuntu 11.04

William R Agosto Padilla agopad at
Wed Aug 31 16:41:18 UTC 2011

Dear Linux Experts,

I have installed Ubuntu 11.04 recently. When I tried using strace, I got an
error message that the modules couldn't be found. A sure sign that strace
was not included in the distribution that I got. I installed strace
However after a restart, I am not able to get strace to work. When I run the

"strace -e trace=network -o ~rkarne/Documents/strace_out.txt"

I get a man page explaining the strace and command options, but it does no
run the command itself. Are you aware of any problems with strace with
Ubuntu 11.04? Also, is "dtrace" the same thing as "strace"? What else do you
recommend I do to be able to trace various processes?

Very Respectfully,


William R. Agosto Padilla
Department of Defense
Computer Scientist, (MSITS)/
Psychology Associate
(443) 479-6907 (Office)
(410) 615-3315 (Cell)
agopad at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Strace-devel mailing list