[PATCH v4 3/8] timespec32: Rename to old_timespec32

Dmitry V. Levin ldv at altlinux.org
Tue Mar 10 01:44:13 UTC 2020

On Mon, Mar 09, 2020 at 05:42:59PM -0700, Alistair Francis wrote:
> The Linux kernel calls the 32-bit timespec struct old_timespec32, so
> let's rename it to be clear.

I don't find old_timespec32 any more clear than timespec32, sorry.
Why add a prefix when the suffix is quite descriptive already?

It's up to kernel people to rename their internal structures as they
please, but we don't have to follow.


More information about the Strace-devel mailing list