Q: minimum supported Linux UAPI headers version
esyr at redhat.com
Mon Mar 2 20:15:13 UTC 2020
As of now, README has several statements regarding the recommended/required
Linux kernel versions, with the "required" being 2.5.46 and "recommended"
being 2.6.18. In fact, there are two separate requirements (among others):
kernel headers version for building strace and kernel version for running it.
And while running strace on 2.6.18 and older kernels is pretty much possible,
it seems that build against some 2.6.18 kernel headers (RHEL 5) is already
sort of broken. And taking into account the fact that RHEL 5 will be even
more dead later this year (end of ELS), I'm not sure if it makes sense
to claim that this kind of build environment is supported. So, I'd like
to propose adding a separate statement regarding minimum kernel headers
version requirement, and my question is: what is the sensible minimum
to set? In other words, what is the oldest kernel headers version people
use for buiding actual versions of strace?
Personally, I still build strace against 2.6.32 kernel headers
(RHEL 6-flavoured), but I suspect that my experience is pretty limited
in that regard and is far from definitive.
More information about the Strace-devel