[PATCH v3] tests/fcntl.c: add test for struct f_owner_ex

Dmitry V. Levin ldv at altlinux.org
Thu Mar 29 14:11:47 UTC 2018


On Thu, Mar 29, 2018 at 05:51:51PM +0800, Zhibin Li wrote:
> On Thu, Mar 29, 2018 at 5:22 PM, Zhibin Li <08826794brmt at gmail.com> wrote:
> 
> > ---
> >  tests/fcntl.c | 41 +++++++++++++++++++++++++++++++++++++++++
> >  1 file changed, 41 insertions(+)
> >
> > diff --git a/tests/fcntl.c b/tests/fcntl.c
> > index 4f62ca2a..606f63bd 100644
> > --- a/tests/fcntl.c
> > +++ b/tests/fcntl.c
> > @@ -69,12 +69,53 @@ test_flock64(void)
> >  #endif
> >  }
> >
> > +static long
> > +test_f_owner_ex_type_pid(const int cmd, const char *const cmd_name,
> > +                        const int type, const char *const type_name,
> > +                        const pid_t pid)
> > +{
> > +       struct f_owner_ex fo = { .type = type, .pid = pid };
> > +
> > +       long rc = invoke_test_syscall(cmd, &fo);
> > +       printf("%s(0, %s, {type=%s, pid=%d}) = %s\n",
> > +              TEST_SYSCALL_STR, cmd_name, type_name, pid, sprintrc(rc));
> > +       return rc;
> > +}
> > +
> > +static void
> > +is_esrch_test_f_owner_ex(const int type, const char *const type_name,
> > +                        pid_t pid, bool is_esrch)
> > +{
> > +       if (is_esrch) {
> > +               test_f_owner_ex_type_pid(ARG_STR(F_SETOWN_EX),
> > +                                        type, type_name, pid);
> > +       } else {
> > +               if (test_f_owner_ex_type_pid(ARG_STR(F_SETOWN_EX),
> > +                                            type, type_name, pid))
> > +                       return;
> > +               test_f_owner_ex_type_pid(ARG_STR(F_GETOWN_EX),
> > +
> 
>                                 type, type_name, pid);
> > +       }
> > +}
> >
> According to Dmitry's advice, I use this function instead of a piece of
> duplicate code.
> 
> > +
> > +static void
> > +test_f_owner_ex(void)
> > +{
> > +       is_esrch_test_f_owner_ex(ARG_STR(F_OWNER_TID), 1234567890, true);
> > +       is_esrch_test_f_owner_ex(ARG_STR(F_OWNER_PID), 1298126790, true);
> > +       is_esrch_test_f_owner_ex(ARG_STR(F_OWNER_PGRP), 1294567890, true);
> > +       is_esrch_test_f_owner_ex(ARG_STR(F_OWNER_TID), 20, false);
> > +       is_esrch_test_f_owner_ex(ARG_STR(F_OWNER_PID), 30, false);
> > +       is_esrch_test_f_owner_ex(ARG_STR(F_OWNER_PGRP), 40, false);
> >
> Since the function  is_esrch_test_f_owner_ex is called many
> times(duplication?), I don't know whether
> it would be better to user a macro now such as:
> 
> define IS_ESRCH_TEST_F_OWNER_EX_ESRCH(cmd)
> is_esrch_test_f_owner_ex_esrch(cmd, #cmd)

I'm not sure I understand your idea given that your
is_esrch_test_f_owner_ex_esrch takes 4 arguments.

I suppose you can drop is_esrch argument (i.e. assume is_esrch == false).

> Beside, I want to to know how to locate indentation problems(or similar
> things) before I send patches?
> I did find something in README-hacking but when I use this:
> 
> git -c core.whitespace=space-before-tab,trailing-space diff-index \
> --check 4b825dc642cb6eb9a060e54bf8d69288fbee4904

btw, I usually enable something like this in the git pre-commit hook.

> I didn't find the indentation problems in my former patch(v2) so I guess
> I'm getting into the wrong direction.
> Anyone can help?

You can play with indent-with-non-tab parameter of core.whitespace
but we don't enforce it (yet?), so it's less useful.


-- 
ldv
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
URL: <http://lists.strace.io/pipermail/strace-devel/attachments/20180329/96fa468c/attachment.bin>


More information about the Strace-devel mailing list