[PATCH 0/8] mmap_cache subsystem (re-factoring)
Dmitry V. Levin
ldv at altlinux.org
Mon Feb 26 23:30:06 UTC 2018
On Sat, Jan 27, 2018 at 05:36:36AM +0900, Masatake YAMATO wrote:
> When we added unwinding feature (activated with -k option), we also added
> a code for caching the entries of /proc/$pid/maps.
> The code for caching was tightly integrated with the code for
> unwinding. However, while prototyping kvm vcpu state dump feature to
> strace, I found the code for caching is useful for other purposes
> than unwinding feature.
> This patch set makes the code for caching usable independently of
> unwinding feature. In the changes, I call the newly separated
> code for caching "mmap_cache subsystem".
>  https://marc.info/?l=kvm&m=151531408406144&w=2
> Masatake YAMATO (8):
> unwind: lift up unw_flush_cache from mmap cache management code
> Introduce mmap_cache subsystem derived from unwind.c
> mmap_cache: Move code for searching an mmap cache from unwind
> mmap_cache: record protection bits
> Lift up mmap_cache_delete invocation from unwind.c
> mmap_cache: add function to enable mmap_cache
> mmap_cache: record device major and minor numbers
> mmap_cache: add customizable search function
Thanks, I'll merge the first 7 of them, with minor corrections
(mostly related to commit messages) and a single build fix.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 801 bytes
Desc: not available
More information about the Strace-devel