aarch64-linux compile problem

Larry Dickson tjoccam at tjoccam.com
Tue Jan 24 16:15:23 UTC 2017

Hello strace developers,

We need strace on our Samsung S2 T710 Android tablet, and I tried to cross-compile it on our Dell XPS-13 (Ubuntu 14.04 LTS) laptop. I went for android-ndk-r13b-linux-x86_64.zip, which is in


and brought it up according to 


(except for the source fetch, which was just a download). OK. Then I downloaded strace-4.15.tar.xz from sourceforge and followed Muzso


except that I fixed the names and substituted aarch64-linux for arm-linux in the ./configure, which worked. (I used aarch64-linux instead of arm-linux because our device CPU is an Exynos 5433, which is an ARMx8-A.)

The make failed with error

# error struct flock64 definition not found in <linux/fcntl.h>

which is an error discussed nowhere on the web, though I can find struct . . . fcntl.h> in three source files.

Thank you for any help you can give!

Larry Dickson
Space Sciences Corporation

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.strace.io/pipermail/strace-devel/attachments/20170124/3761f550/attachment.html>

More information about the Strace-devel mailing list