[PATCH v2 1/3] inet_diag: rename decode_inet_addr to decode_inet_diag_hostcond_addr

JingPiao Chen chenjingpiao at gmail.com
Tue Aug 22 06:45:47 UTC 2017


decode_inet_addr only use to decode inet_diag_hostcond.addr,
rename to decode_inet_diag_hostcond_addr.

* netlink_inet_diag.c (decode_inet_addr): Rename to
decode_inet_diag_hostcond_addr.
(decode_inet_diag_hostcond): Replace decode_inet_addr with
decode_inet_diag_hostcond_addr.
---
 netlink_inet_diag.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/netlink_inet_diag.c b/netlink_inet_diag.c
index 34fffc8..0298af5 100644
--- a/netlink_inet_diag.c
+++ b/netlink_inet_diag.c
@@ -59,10 +59,10 @@ print_inet_diag_sockid(const struct inet_diag_sockid *id, const uint8_t family)
 }
 
 static void
-decode_inet_addr(struct tcb *const tcp,
-		 const kernel_ulong_t addr,
-		 const unsigned int len,
-		 const int family)
+decode_inet_diag_hostcond_addr(struct tcb *const tcp,
+			       const kernel_ulong_t addr,
+			       const unsigned int len,
+			       const int family)
 {
 	union {
 		struct in_addr  a4;
@@ -114,8 +114,8 @@ decode_inet_diag_hostcond(struct tcb *const tcp,
 
 	if (len > sizeof(cond)) {
 		tprints(", ");
-		decode_inet_addr(tcp, addr + sizeof(cond),
-				 len - sizeof(cond), cond.family);
+		decode_inet_diag_hostcond_addr(tcp, addr + sizeof(cond),
+					       len - sizeof(cond), cond.family);
 	}
 	tprints("}");
 }
-- 
2.7.4





More information about the Strace-devel mailing list