[PATCH v4 00/37] ldv/unwind: improve stacktrace feature
Dmitry V. Levin
ldv at altlinux.org
Tue May 13 23:58:22 UTC 2014
On Wed, Apr 16, 2014 at 03:32:58PM +0900, Masatake YAMATO wrote:
> This patch set is for improving stacktrace feature.
> The review result of Dmitry V. Levin <ldv at altlinux.org> are
> reflected.
>
> You can try the patch incremental. About any n (0 < n < 38), you can
> apply patches from 1 to n to the source tree, compile it and run ./strace.
Thanks. I've pushed this to ldv/unwind branch with minimal changes:
> Masatake YAMATO (37):
> unwind: fix a bug in range updating of binary search
> unwind: make alloc_mmap_cache unwind.c local
> unwind: delete mmap cache in free_libunwind_ui
> unwind: add unwind_ as prefix to functions exported from unwind.c
> unwind: rename unwind_delete_mmap_cache to unwind_cache_invalidate
> unwind: introduce stacktrace_walker
unchanged or with slight commit message corrections
> unwind: introduce unwind.c own debug macro
removed trailing semicolon
> unwind: introduce queue_t for capturing stacktrace
> unwind: consider multi-threading when rebuilding mmap cache
> unwind: call unwind_tcb_fin before printing detached message
> unwind: report expected backtracing error
> unwind: enable dwarf cache of libunwind
> unwind: introduce markers specifying the needs of special care in
> unwinding
unchanged or with slight commit message corrections
> unwind: x86_64: mark system calls with SI and SE
> unwind: i386: mark system calls with SI and SE
> unwind: arm: mark system calls with SI and SE
> unwind: x32: mark system calls with SI and SE
> unwind: xtensa: mark system calls with SI and SE
> unwind: tile: mark system calls with SI and SE
> unwind: sparc: mark system calls with SI and SE
> unwind: sh64: mark system calls with SI and SE
> unwind: sh: mark system calls with SI and SE
> unwind: s390x: mark system calls with SI and SE
> unwind: s390: mark system calls with SI and SE
> unwind: powerpc: mark system calls with SI and SE
> unwind: or1k: mark system calls with SI and SE
> unwind: mips: mark system calls with SI and SE
> unwind: microblaze: mark system calls with SI and SE
> unwind: metag: mark system calls with SI and SE
> unwind: m68k: mark system calls with SI and SE
> unwind: hppa: mark system calls with SI and SE
> unwind: bfin: mark system calls with SI and SE
> unwind: avr32: mark system calls with SI and SE
> unwind: arc: mark system calls with SI and SE
> unwind: alpha: mark system calls with SI and SE
> unwind: aarch64: mark system calls with SI and SE
replaced with a single commit that does essentially this:
sed -ri '/osf_/{p;d};s/(TM[^,]*)(,[^"]+"[^"]*(mmap|mprotect|munmap|brk|mremap|remap_file_pages))/\1|SI\2/;s/(TI[^,]*)(,[^"]+"[^"]*shm[ad]t)/\1|SI\2/;s/(TP[^,]*)(,[^"]+"[^"]*execv)/\1|SE|SI\2/;s/(TP[^,]*)(,[^"]+"[^"]*exit)/\1|SE\2/' linux/*/syscallent*.h
> unwind: stacktrace capturing and mmap cache invalidating at
> trace_syscall_entering
unchanged or with slight commit message corrections
Commit messages of this patchset do not meet our commit log requirements
described in README-hacking; either commit messages have to be corrected
or requirements have to be relaxed.
Besides that, the patchset looks OK for master.
--
ldv
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.strace.io/pipermail/strace-devel/attachments/20140514/2b58c6dc/attachment.bin>
More information about the Strace-devel
mailing list