[PATCH] don't name parameter "errno"
dvlasenk at redhat.com
Wed May 25 13:35:46 UTC 2011
On Wed, 2011-05-25 at 02:24 +0400, Dmitry V. Levin wrote:
> On Tue, May 24, 2011 at 10:41:31PM +0200, Denys Vlasenko wrote:
> > http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/errno.h.html
> > says:
> > "The <errno.h> header shall provide a declaration or definition for
> > errno. The symbol errno shall expand to a modifiable lvalue of type int.
> > It is unspecified whether errno is a macro or an identifier declared
> > with external linkage. If a macro definition is suppressed in order to
> > access an actual object, or a program defines an identifier with the
> > name errno, the behavior is undefined."
> > strace source does use identifier "errno" at a parameter of one
> > function. I propose to rename it, so that we don't risk
> > getting build breakage here on obscure platforms or libcs.
> It certainly won't harm, OK with me.
Thanks! Applied to git.
More information about the Strace-devel