RFC: path display and path filtering features.
Grant Edwards
grant.b.edwards at gmail.com
Tue Mar 15 04:38:51 UTC 2011
On 2011-03-14, Dmitry V. Levin <ldv at altlinux.org> wrote:
> On Mon, Mar 14, 2011 at 10:47:18AM -0500, Grant Edwards wrote:
>> On Sat, Mar 12, 2011 at 03:48:08PM -0600, Grant Edwards wrote:
>>
>> > Attached are my current diffs. I've merged recent changes from the
>> > main git repository and addressed various comments.
>> >
>> > The notable changes are addition of handling for 'select' syscalls,
>> > 'poll' syscalls, and 'epoll_ctl'.
>>
>> This set of diffs has had a little more cleanup done an code that
>> checks paths residing in user-space was re-factored into a separate
>> function.
>
> Thanks. I have two comments after skimming through the patch:
>
> 1. never use alloca(3) with arbitrary size coming from untrusted input:
> it's unsafe, because alloca(3) has no means to indicate a memory
> allocation failure;
I'll change it to a malloc.
> 2. getpath() sounds a bit generic, I suggest renaming it to something
> more specific, e.g. getfdpath().
That sounds good.
--
Grant
More information about the Strace-devel
mailing list